Problemas al instalar el paquete ‘rgl’ en RStudio

Problema

Quizá si tratas de instalar el paquete rgl directamente en RStudio de la siguiente manera:

install.packages("rgl")

Obtengas como resultado errores.

Solución

Los errores que obtienes son debidos a problemas de dependencias. A continuación muestro paquetes que tendrás que instalarte en línea de comandos para evitar errores:

sudo apt-get install libgl1-mesa-dev
sudo apt-get install libglu1-mesa-dev
sudo apt-get install libglu-dev
sudo apt-get install libpng12-dev
sudo apt-get install libx11-dev
sudo apt-get install libxt-dev
sudo apt-get install x11proto-core-dev

Una vez instalados esos paquetes, ahora si, ve a RStudio y vuelve a ejecutar:

install.packages("rgl")

Ahora se debería ejecutar correctamente.

Referencias

[R-es]rgl

Advertisements